Google Wallet Raises Minimum OS Requirements for Android and Wear OS

Google Wallet will increase its minimum OS requirements to Android 9 or higher and Wear OS 2.x or higher starting June 10, 2024, citing security updates. The change will affect users with devices running Android Nougat and Oreo, but most users will remain unaffected.

author-image
Aqsa Younas Rana
New Update
Google Wallet Raises Minimum OS Requirements for Android and Wear OS

Google Wallet Raises Minimum OS Requirements for Android and Wear OS

Google Wallet is set to increase its minimum operating system requirements for Android devices and Wear OS smartwatches starting June 10, 2024. The company cites the need for security updates as the primary reason behind this change.

Currently, Google Wallet supports devices running Android 7.0 or higher. However, come June 10, the minimum OS version requirement will be raised to Android 9 or higher for Android devices and Wear OS 2.x or higher for smartwatches. Google Wallet states, "security updates aren't available for Android versions below 9." The company emphasizes the importance of being able to send security updates to devices to ensure the safety of features like tap-to-pay transactions.

Why this matters: This change highlights the ongoing struggle to balance security with compatibility in the digital payments space, and it may set a precedent for otherdigital wallet services to follow. As mobile payments become increasingly ubiquitous, ensuring the security of these transactions will be crucial to maintaining user trust and preventing widespread fraud.

The change is expected to impact users with devices running Android Nougat (7.0, 7.1) and Oreo (8.0, 8.1). However, the majority of Android users are likely to remain unaffected, as Android 9 Pie has a cumulative distribution of 86.4% as of October 2023.

Google Wallet, launched in 2022, initially had a minimum OS version requirement of Android 5.0. Wear OS 2, which powers Google's smartwatch platform, was originally based on Android 8.0 Oreo but later received an update to Android 9.0 Pie. Google Wallet, formerly known as Google Pay, relies on Google Play services, which ended support for Android 4.4 KitKat in August 2023.

The upcoming change in minimum OS requirements for Google Wallet highlights the company's commitment to maintaining a secure environment for its users. By mandating the use of more recent Android versions, Google aims to ensure that its digital wallet platform remains protected against potential security vulnerabilities and threats.

Key Takeaways

  • Google Wallet raises min. OS requirement to Android 9 or higher on June 10, 2024.
  • Change affects devices running Android Nougat (7.0, 7.1) and Oreo (8.0, 8.1).
  • Security updates are the primary reason for the change.
  • Majority of Android users (86.4%) on Android 9 Pie will remain unaffected.
  • Change aims to ensure a secure environment for Google Wallet users.